Can't download the driver - STATION-DRIVERS

Can't download the driver

More
5 months 4 weeks ago #5965 by Tek
I'm trying to download a driver but when I click on the "download" button nothing happens and the same website tab opens.

Please Log in or Create an account to join the conversation.

More
5 months 4 weeks ago #5966 by Tek
Replied by Tek on topic Can't download the driver
Just in case, I will attach the link on which I am trying to download the driver:
www.station-drivers.com/index.php/en/dri....1)-WHQL/lang,en-gb/

Please Log in or Create an account to join the conversation.

More
5 months 4 weeks ago - 5 months 4 weeks ago #5967 by SM-003
Replied by SM-003 on topic Can't download the driver

Just in case, I will attach the link on which I am trying to download the driver:
www.station-drivers.com/index.php/en/dri....1)-WHQL/lang,en-gb/

Here is the direct download link  
Recommending to use a download manager app (i.e. IDM) to get the download link without any hassle. 
Last edit: 5 months 4 weeks ago by SM-003.
The following user(s) said Thank You: Tek

Please Log in or Create an account to join the conversation.

More
5 months 3 weeks ago - 5 months 3 weeks ago #5987 by erpster96
Replied by erpster96 on topic Can't download the driver

I'm trying to download a driver but when I click on the "download" button nothing happens and the same website tab opens.


what web browser were you using, Tek?

try downloading a driver thru either Pale Moon browser or Seamonkey browser suite as I don't have these download problems from those specific browsers and recent Firefox & Chrome browser versions don't allow downloads from station drivers site by default (and need to add an exception or be "white listed" thru FF/Chrome's content settings).
Last edit: 5 months 3 weeks ago by erpster96.

Please Log in or Create an account to join the conversation.

More
5 months 2 weeks ago #6017 by Galixte
Replied by Galixte on topic Can't download the driver
Yes you’re right, it’s an issue from the server configuration which is badly set.

Take a look here for a workaround: www.station-drivers.com/index.php/fr-ca/...ownload?start=6#5900

My hardware setups  |  Communauté EzCom  : « Traductions d’extensions & styles pour phpBB 3.2.x & 3.3.x ».

Please Log in or Create an account to join the conversation.

Time to create page: 1.009 seconds